| Revision:

root / trunk / code / projects @ 1373

Name Size Revision Age Author Comment
  autonomous_recharging 634 about 13 years Evan Mullinix red should be fixed. testing more plz.
  colonet 1354 almost 12 years Chris Mar adding keyboard remote control for
  diagnostic_station 1318 almost 12 years Brad Neuman Martin updated some of the tests test_motors is...
  girlscouts 895 over 12 years Brad Neuman girl scouts!! yay!!!!
  hunter_prey 1373 over 11 years Brad Neuman Added hunter-prey WIP code. There is a bug with...
  i2c_charge_station 666 about 13 years Kevin Woo Added charging station's i2c_auto code in so th...
  libdragonfly 1372 over 11 years Abraham Levkoy Moved prototype for linearize_distance and cons...
  libwireless 940 over 12 years Ryan Cahoon Prototype JNI (Java Native Interface) for libwi...
  mapping 1361 over 11 years Justin Scheiner Made some small changes reading through the cod...
  object_manipulation 775 almost 13 years David Schultz implemented averaging with older data to smooth...
  scheduler 33 over 13 years James Kong added autonomous_recharging and scheduler folde...
  template 1097 about 12 years Martin Herrmann Makefile OS autodetection
  test 1369 over 11 years Evan Mullinix updated unit test of motors

Latest revisions

# Date Author Comment
1373 09/03/2009 08:02 PM Brad Neuman

Added hunter-prey WIP code. There is a bug with using BOM and rangefinder

1372 09/03/2009 01:12 AM Abraham Levkoy

Moved prototype for linearize_distance and constants MIN_IR_ADC8 and
MAX_IR_ADC8 from rangefinder.c to rangefinder.h. Added Doxy comments for these
items. Realize that linearize_distance was probably intended to be hidden from
the average user, but doxy errors compelled me to act.

1371 09/02/2009 11:37 PM Rich Hong

Remove some unused code in encoders

Also update binary and docs

1370 09/02/2009 10:04 PM David Schultz

documentation fix

1369 09/02/2009 08:14 PM Evan Mullinix

updated unit test of motors

1368 09/02/2009 07:38 PM David Schultz

test of usb read/write functions is successful

1365 09/01/2009 01:02 AM David Schultz

removed dragonfly_init() from each unit test and renamed files to comply with new naming convention.

1364 09/01/2009 12:36 AM Brad Neuman

changed main.c in the test project to call dragonfly_init

1363 09/01/2009 12:25 AM Brad Neuman

made the test framework a bit more clear (or maybe more confusing?)

1362 08/31/2009 10:18 PM David Schultz

Added test for usb output functions

View revisions

Also available in: Atom