Project

General

Profile

Revision 1182

Made filenames more consistent
Made function names more consistent
Introduced separate functions for hardware components

View differences:

main.c
5 5
#include "../common/comm_station_robot.h"
6 6

  
7 7
#include "global.h"
8
#include "station_hardware.h"
8
#include "hardware.h"
9 9
#include "tests.h"
10
#include "self_test.h"
11
#include "comm_server.h"
10 12

  
11 13
void interactive_main (void)
12 14
{
......
47 49

  
48 50
    orb_init_pwm ();
49 51
	hardware_init ();
50
	server_comm_init ();
52
	comm_server_init ();
51 53

  
52 54
	orb1_set (255, 0, 0); usb_puts("# Initializing wireless" NL);
53 55
	xbee_init ();

Also available in: Unified diff